Disable RustPP

xandeturf

Moderator
Moderator
Nov 4, 2015
132
25
18
31
I copied the 3 files from the Prepatched_Assembly folder and threw it in Managed, let's see what it's going to do now. Hope it solves, my projects were stopped because of this problem.
 

salva

Friendly self-taught developer
Administrator
Jan 31, 2016
576
452
63
I copied the 3 files from the Prepatched_Assembly folder and threw it in Managed, let's see what it's going to do now. Hope it solves, my projects were stopped because of this problem.
If you were not using pre-patched files, it is very likely that most of the problems you were experiencing would be solved (I guess, but that's a mystery), lucky !!
 

xandeturf

Moderator
Moderator
Nov 4, 2015
132
25
18
31
Today I had a different uLink error.
The player used "/ home 3" several times without teleporting. I use SafeTeleportTo to do teleportation. And after a few minutes,
[2/10/2017 6:34:46 PM] === Fougerite uLink === flood a warning and the player was still online.

I was forced to restart the server to work.
 

Attachments

DreTaX

Probably knows the answer...
Administrator
Jun 29, 2014
4,028
3,274
113
At your house.
github.com
Today I had a different uLink error.
The player used "/ home 3" several times without teleporting. I use SafeTeleportTo to do teleportation. And after a few minutes,
[2/10/2017 6:34:46 PM] === Fougerite uLink === flood a warning and the player was still online.

I was forced to restart the server to work.
That's annoying. I wonder what the heck can cause ulink problems. Did the player lose connection?
 

salva

Friendly self-taught developer
Administrator
Jan 31, 2016
576
452
63
Today I had a different uLink error.
The player used "/ home 3" several times without teleporting. I use SafeTeleportTo to do teleportation. And after a few minutes,
[2/10/2017 6:34:46 PM] === Fougerite uLink === flood a warning and the player was still online.

I was forced to restart the server to work.
I remember having similar ones after a player did (/home), but I do not have logs available because I did wipe today, I will be careful if it happens to me again.
 

Jakkee

Plugin Developer
Plugin Developer
Contributor
Jul 28, 2014
1,465
687
113
Australia
Try teleporting home, Closing the game Alt + F4 or clicking the x, then check console for callback errors.
This is maybe where the ulink errors come from (Players force closing rust)